Symptom:
You are trying to link the Intuit Payment Service to your QuickBooks company file, and you are receiving an error message saying "Oops, something went wrong." when trying to log into your merchant services account.
Cause:
This issue is typically caused by website and security settings that are set within your QuickBooks application.
Resolution 1:
1. Open QuickBooks
2. Click Help on your toolbar
3. Click Internet Connection Setup
4. Leave the Internet option alone as the default setup is correct and click Next
5. Click Advanced Connection Settings
6. There will be a new window that appears, click Privacy on that new window
7. There you will see Internet cookies, which must be set to Accept All Cookies
8. If they're not set to Accept All Cookies, you will need to hover your mouse over the hash marks and scroll down until the setting changes to Accept All Cookies and then try to log into merchant services again
9. If they are set to Accept All Cookies, proceed to Resolution 2
Resolution 2:
1. Open QuickBooks
2. Click Help on your toolbar
3. Click Internet Connection Setup
4. Leave the Internet option alone as the default setup is correct and click Next
5. Click Advanced Connection Settings
6. There will be a new window that appears, click Advanced on that new window
7. Click Reset towards the bottom, and a new window will appear
8. Enable Delete personal settings and click Reset
9. After it's reset, close QuickBooks and reopen it to try to log into your merchant services account again